PHP 5.3 Now Available

Jan 27th, 2011

We have now made PHP 5.3 available to all customers currently subscribing to a Linux hosting plan. Customers now have the option to utilize PHP 4.4, 5.2, or 5.3 for their hosting services. We have also recently upgraded the version of 5.2 to the latest stable release version 5.2.17.

Linux customers can change their PHP version in the Account Manager in the PHP Settings section. You can select a different PHP version for each of your hosted web sites. Please be aware that some scripts are coded to work with a specific version of PHP, so you will want to review your code to make sure it will work properly if you select a later version of PHP.

PHP 5.3 is an exciting new release which is a major improvement in the 5.X series and includes a large number of new features and bug fixes.

Some of the key features of PHP 5.3 include:


  • Support for namespaces

  • Late static binding

  • Lambda Functions and Closures

  • Syntax additions: NOWDOC, ternary short cut "?:" and jump label (limited goto), __callStatic()

  • Under the hood performance improvements

  • Optional garbage collection for cyclic references

  • More consistent float rounding

  • Deprecation notices are now handled via E_DEPRECATED (part of E_ALL) instead of the E_STRICT error level

  • New bundled extensions: ext/phar, ext/intl, ext/fileinfo, ext/sqlite3, ext/enchant

  • Over 140 bug fixes and improvements to PHP, in particular to: ext/openssl, ext/spl and ext/date


PHP 5.3 also drops several extensions and unifies the usage of internal APIs. Users should be aware of the following known backwards compatibility breaks:


  • Parameter parsing API unification will cause some functions to behave more or less strict when it comes to type juggling


For more information about PHP please visit the PHP web site at http://www.php.net

AWARDS

We've been a leader in the web hosting industry since 1999.
Our focus on premier customer service, affordable prices, and maximum reliability has earned us a few awards.